Documented below is a list of commonly faced issues with the Orchestration server installation, along with their causes and the solutions.
Common Issues in Orchestration Server Installation
Issue:
You do not have permissions to execute the .msi installer file / You don’t have sufficient Privileges to Start System Servers
Cause1:
This issue occurs when you don’t have Administrative access to execute files.
Solution: You need Administrative access to the windows server on which the Orchestration server is being installed.
Cause 2:
This issue can occur if you don’t have .NET Framework 3.5 Windows feature Enabled.
Solution:
Check whether the .NET 3.5 windows feature is enabled or not.
Click on the Start button and search server Manager
Go to Server manager
In the top right corner, click on the Manage tab
Click on Add Roles and Feature
Click on Next (In before you begin page)
Click on Next (In Installation type page after selecting radio button Role-based or feature-based installation)
Click on Next (In Server selection page, after selecting a radio button, select a server from the server pool and then select your windows server from the list below)
Click on Next (In Server Roles page after selecting checkbox File and Storage Services )
Click on Next (In Feature Page, expand .NET Framework 3.5 Feature and select checkbox .NET Framework 3.5 (includes .NET 2.0 and 3.0) is not selected)
Click Install if you are selecting the above-mentioned checkbox
Issue:
If an unexpected error occurs while executing the .msi installer file
Cause 1:
This issue can occur if you don’t have .NET Framework 3.5 Windows feature Enabled.
Solution:
Check whether the .NET 3.5 windows feature is enabled or not.
Click on the Start button and search server Manager
Go to Server manager
In the top right corner, click on the Manage tab
Click on Add Roles and Feature
Click on Next (In before you begin page)
Click on Next (In Installation type page after selecting radio button Role-based or feature-based installation)
Click on Next (In Server selection page, after selecting a radio button, select a server from the server pool and then select your windows server from the list below)
Click on Next (In Server Roles page after selecting checkbox File and Storage Services )
Click on Next (In Feature Page xxpand .NET Framework 3.5 Feature and select checkbox .NET Framework 3.5 (includes .NET 2.0 and 3.0) is not selected)
Click Install if you are selecting the above-mentioned checkbox
Cause 2:
This issue can occur when another folder has the same name as the installation folder, inside the installation directory.
Solution:
You need either rename or remove the pre-existing folder.
Common Issues when resetting the Secret key of an Orchestration Server
Issue:
If you are not allowed to edit the secret key in the osr.conf file from the Orchestration server folder.
Cause1:
This issue occurs when the Orchestration Server service is still running
Solution:
Stop the ‘Orchestration Server’ service.
Cause2:
This issue can occur when you don’t have Admin’s Access to edit files.
Solution:
You need Admin’s Access.
Common Issues when Orchestration Server is Offline
Issue:
If Orchestration Server is showing offline in the Freshservice Instance.
Cause1:
This issue can occur when Orchestration Server Service is not running
Solution:
You need to restart the Orchestration Server Service.
Cause2:
This issue can occur when the secret key in osr.conf is not the same which was generated on Freshservice Instance.
Solution:
You need to copy the secret key from Freshservice Instance to osr.conf and restart the Orchestration Server Service.
Cause3:
This issue can occur when you have enabled Proxy settings during installation and Credentials entered by you then are not correct.
Solution:
You need to Stop the Orchestration Server Service and update application.conf with a proper proxy credential in application.conf.
Change proxy.enable = true and update the following
proxy.hostname: Give the private IP of the proxy server.
proxy.port: Give the port number of the proxy server
proxy.username: Give the username of the proxy server
proxy.password: Give the password of the proxy server.
proxy.type: Give the Protocol used #this can be http,socks4,socks5
You will find application.conf (Go to Installation Destination folder → Orchestration Server → Click on osr folder → Go inside Config Folder, you will find application.CONF file,
Cause4:
This issue can occur when Freshservice Instance is not accessible
Solution:
You need to check from the browser whether Freshservice Instance or not. If not then contact your network team.
Common Issues in Orchestration Server Uninstallation
Issue:
If Orchestration Server is not getting completely remove from your computer
Cause1:
This issue can occur when you are inside the Installed Orchestration Server Directory/Folder
Solution:
Move out of the installed Orchestration Server Directory/Folder.
Cause2:
This issue occurs when you have opened the Installed Orchestration Server Directory/Folder, in the terminal/command line
Solution:
Exit the opened terminal/command line.
Cause3:
This issue occurs when you have moved the Installed Orchestration Server Directory/Folder to the new place after Installation.
Solution:
Copy the Installed Orchestration Server Directory/Folder to its original position.
You can find the path under “OSR_HOME” Environment Variables in your system.