Start a new topic
Solved

SDK Documentation Unclear on what is the Current Version of CLI and Node

The SDK documentation for freshdesk and freshservice differ in regards to what version to install of both Node.js and the FDK CLI. I tried installing FDK ver 6.0 and it would not work for me. However if I installed an older version and use Node 8.10 I can utilize the tools and produce applications. 


However, the freshdesk documentation says that Node version 8.10 has been deprecated and to install FDK version 6.0.0 and use Node ver 10.18. 


Do I need to use different version based on the platform I am developing for (freshdesk, freshservive, freshchat, etc.)? A little clarity in this area would help tremendously as I would think we want to be using the latest versions of the developer tools.

Hi Zachary,


Sorry for the confusion caused. It may take some time to reflect changes across docs. We will work on it to speed up this process.


No, you don't need different versions for different products.


Node version: 10.18 can be used alongside FDK v6.0.0


Are you sure when you first tried installing FDK v6, the node version was 10.18 ?





That was the problem, I was not sure on what version of Node I should be using to install the CLI. I kept getting notified that an update to the CLI was available and when I would try to update it would fail. Makes sense now since the current version of the FDK I was using was built for an older version on Node. Once installed correct version of Node, I had no problem upgrading the FDK.


Thank you for the clarification. 

Login or Signup to post a comment