Start a new topic

USER FIELD MAPPING defaults are wrong for MSP Mode

When you have to "MSP Mode" FreshService basically renamed "Department" to "Company" as well as some other changes.


The issue is that the default USER FIELD MAPPING (Discovery > Probe > Setting) maps Department (AD) -> Department (FreshService).


And so when you enable MSP mode you end up with Department (AD) -> Company (Fresh Service).


And so when the import runs it will create new "Companies" for any "Department" values from any of our client's AD.


Is created a big mess. Completely wrecks the Timesheet Report as tickets are linked to the wrong Company.


Further you cannot even edit the default USER FIELD MAPPING - so I have had to create a custom one that does not map this field (we are linking the Contact to the Company by the email domain anyway) - then I just need to remember to apply it each and every time I add a new probe in - as I cannot make my one the new default.


2 people have this problem

Hi Ryan,


Thank you for bringing this to our attention. It looks like there is a flaw in the way Departments/Companies are synced. However, let me have this workflow discussed with our product team and get back to you with an update on this. 

 

As you have suggested, you can proceed with the AD user sync through custom mapping. Also, feel free to reach out to support if you need to clear the departments that have been created and we will be able to help you clean up the mess caused. 


Thanks for using Freshservice! 

What is needed here is to allow us to edit the default mapping, or set our own custom mapping as the default.



Login or Signup to post a comment
JS Bin