Start a new topic

Inconsistent use of solution tags in end user search

When a requester uses the search bar in the portal, solution article tags are not included in the search (only the title and article content). However, when they type in the subject line of of the new ticket form, the suggested solutions tool does search the tags (which is ideal).


We've found it to be a best practice to use tags for alternative search methods such as abbreviations, common misspellings, and system names (which may not be in the solution title or article body because it is the category or folder name). This allows us to avoid having those search terms visible in the solution article.

Hi Andrew, 


Is my understanding of your problem correct: 


When a user searches in the support portal search bar, for a tag, no results come up but when the same search query is used in the 'new ticket form' search, solution articles are returned which have that search query in its tags? 


joe


Precisely

Hi Andrew


I tested this. It seems to work fine. I added an article and tagged it as 'BYOD'. The word 'BYOD' does not appear anywhere in the article. When I search for BYOD in the requester portal and in the 'new ticket form', I was able to get the article. 



joe

Thank you Joseph, I am now seeing the correct behavior in my environment as well.


Is there perhaps any type of search cache that could have delayed it from working for a short time just after a tag is added?

happy to help! :)


It takes less than a minute to index, so if you searched for it within seconds of adding a tag, it is possible the search didnt return the correct results. 


cheers

joe

Login or Signup to post a comment
JS Bin