Start a new topic

Remove "On Behalf Of" from Helpdesk Emails


When emails are received from our internal vanity email it shows as "IT Support <freshservice email address> on behalf of IT Support <internal vanity email address>"

I thought this was a bug but it turns out there is not an option at present for emails to appear as if they come straight from the vanity email, rather than "on behalf of". 

Please implement the ability for emails to appear as if they are coming from the vanity email only, i.e. it should just display: "IT Support <vanity email address>"

My team are really keen on this feature to avoid confusion for our internal users.

(7.92 KB)

4 people like this idea

I too thought on this, however i think it might be a outlook issue rather than a freshservice issue. 

if you test this using a public email service like outlook or gmail it shows fine. 

I've spent most of the afternoon trying various configurations in Exchange Online, and done some further digging. According to a post on Quora, "on behalf of" appears only when the sender system adds the "Sender:" header. Most ESPs have the option to enable or disable it. 

So that, coupled with the fact that Freshservice's own support asking me to raise this as a feature request, suggests it is possible from Freshservice's side. We have Zendesk in use for another team and they have no issues, emails appear without "on behalf of" and use an email in our domain just fine, so I still think there's a potential for Freshservice to provide a solution to this request.



Just to note even Freshdesk doesn't have this issue, emails appear as if they come from our internal address just fine. 

are these forums monitored by freshservice support team?


Sorry for the delay in reply to this Post.

Freshdesk uses Mailgun as an Email service and Freshservice uses Sendgrid, hence the difference. 

We are still testing Mailgun as our Email service Provider and we are also working on Custom mailbox feature which will solve this issue. Once the Custom mailbox feature comes up, customers can make use of their own IMAP/SMTP settings and this On behalf of, will not be shown.

We hope to get this feature in 1-2 months time, after testing with different Mail services like Exchange / Lotus Notes / Gmail etc



1 person likes this

Hi Vijay,

Fantastic, thanks for your response. Good to hear this will be resolved in a few months, I'll be pushing to get Freshservice implemented for my organisation fully with a paid subscription shortly.

Many thanks,


Any update on this? 

Any update on this?

Indeed, 1-2 months has come and gone.

And another month.

Well it hasn't been documented but they seem to have fixed it, whenever I get emails now they no longer have the "on behalf of" section, it's just one email address.

Login or Signup to post a comment