Start a new topic
Solved

Anyone else have broken Disptach'r webhooks?

I've tried everything and I can't get webhooks to trigger from Dispatch'r.  I can get the same webhook to trigger through Observer but not Dispatch'r.


I even tried implementing this dispatch'r webhook solution provided by FreshService as a test but no luck. https://support.freshservice.com/support/solutions/articles/218075-creating-a-change-request-through-dispatch-r-using-a-webhook


I've tried setting a super simple webhook that just posts the results to https://requestb.in but nothing shows up.


Anyone been able to get a webhook to trigger from dispatch'r?

Hi Steven,

Thank you for reaching out.

Please find the screenshot of the webhook below.

image


Sample code:


URL:https://domain.freshservice.com/helpdesk/tickets.json

Make sure you enable "Requires Authentication" and use the email address and password.


{
 "helpdesk_ticket":{
     "description_html":" Test",
     "subject":"Test",
     "email":"{{ticket.from_email}}",
      "status":2
 }
}


Jayesh
Freshservice Support

Hi All, just to update, there wasn't anything wrong with my settings. Somehow our account became blacklisted so the email and webhook functionality stopped working.  


Support had to have our instance removed from the blacklist. Hope this helps for future people.

Login or Signup to post a comment
JS Bin