Thank you Sysadmins! Show some love, join a contest, and win $100 USD, you deserve it all. Win $100 USD

Start a new topic
Implemented

Microsoft Teams app for Freshservice

The Microsoft Teams apps for Freshservice send notifications to agents on Teams regarding newly assigned tickets and also regarding updates being made to them. Agents can also now interact with the bot to fetch information regarding tickets and changes to help collaborate in the context of the ticket/change.


Use case 1: IT Agents can now get notified in MS Teams regarding newly assigned incidents. The agents will also be notified about conversations being added to the ticket and also regarding any updates made to the status and priority. Agents can also perform certain quick actions like adding notes/reply on the tickets within the Teams interface.(Mocks below to showcase the interaction)

image



Use case 2: Agents can now interact with the bot (either one to one or can be used inside a team) to fetch contextual information about tickets and changes, collaborate and perform certain quick actions without leaving the Team’s interface. (Mocks below to showcase the interaction)

image


50 people like this idea

Will this work if we have MSP enabled?

Hi Everybody, if you are facing issues in setting up the Freshservice <> Microsoft Teams integration, please create a ticket at support.freshservice.com so that our team can help you out asap.

@Marcella, it should work in the MSP account. However, only one Freshservice instance can be tied to only one tenant of Microsoft Teams. It is a one to one mapping today. 

Can someone update this when the permission issue is solved? Thanks :)

Hi Everyone, we have reached out to you via the support tickets to fix the permission related issue. You can follow the detailed solution article here. If you still face any issues, please raise a support ticket at support@freshservice.com so that we can help fix the issue. 

I had it working Friday but go to look today and asked the service bot to fetch group tickets and today is is saying that it is installed in Teams and not in Freshservice which is crap as I had installed it that way on Friday.  This App with Teams is awful!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  FIX IT and quick or I'm leaving Freshservice for a service who cares for its customers.

ServiceBot is not listed for me. Have searched in the app and online.

Is ServiceBot limited to certain types of customers, or certain geographic regions, or certain tenants?

@Jeff, I have started a support thread with you regarding the issue. My team is looking into it with high priority. We will revert to you with a fix asap. In the meantime, if you have any queries, feel free to send a reply on that thread so that we can help you out asap. 


@Joshua, just checked with the Microsoft team.  From Team's side, the app is live for all tenants globally. However, the app may not appear for specific Teams tenants if the Teams admin has disabled the same in Teams admin portal. If you are still not able to see the app, I would request you to reach out to your Microsoft Team's POC to help fix the issue. 

 We're still having the permissions issue.  I've completed the steps posted sevreal times (in the correct order).

I'm having the same issues but not sure I really want to continue to troubleshoot the issues as it seems their servicebot connector just doesn't work.

It's all working for me after help from Support.  It does what they said it would do.  Other than a few hiccups they delivered what they said.


@Donald, thanks for the confirmation. Apologies for the initial round of inconvenience caused. As you start using the app, would love to get your feedback about the same.


@Jeff, @Jonathan my team is trying to coordinate a suitable time for a quick screenshare session with you to help you fix the issue. I understand the initial experience has been slightly frustrating and we are committed to helping you out asap. 



Hey,


We're also getting the permission error, we installed in our Fresh Service first as advised but every time I install on Teams then try to run a command You don't have permission to perform this action is returned.


Malcolm

I was advised by support that your O365 domain had to be the same on Freshservice. I don't know if that has any bearing on the Permission error but using the same domain on both Fresh and O365 is not an option for us as we use GSuite for our mail handling and O365 for the Office applications.To update it would require moving our mail handling from Google to Microsoft - which isn't an option for us especially for one app integration.

We are waiting for the fix which Freshservice claims they are working on.  We are an Office 365 tenant and use Freshservice.

@Jeff, we have been trying to reach out to you for a suitable time to get on a call to fix the issue. Can you please help us with a couple of your available time slots so that my team can get the issue resolved asap. You can reply on the ticket that we created on behalf of you to address the integration issue.


@Malcolm, I have created a support ticket on behalf of you and suggested the next steps. Also have looped in my team to help you if the issue persists.

Login or Signup to post a comment