Start a new topic

Unable to install FDK 4.6.1

After installing FDK 4.3.2 as directed on the Developers documentation (https://developers.freshservice.com/docs/quick-start/#install_the_sdk), the version command noted I was not running the latest version of the FDK.


Figuring I should probably be on the latest version, I attempt to install the latest version of the FDK using the following command:


sudo npm install https://dl.freshdev.io/cli/fdk-4.6.1.tgz -g


However, during installation, I'm receiving quite a few notices, including:


npm WARN deprecated json-schema-faker@0.5.0-rc13: Broken not support

npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.

npm WARN deprecated nomnom@1.5.2: Package no longer supported. Contact support@npmjs.com for more info.

npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.

npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.

npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.


There are two bigger problems that appear to be preventing the installation of the latest FDK:


/usr/local/bin/fdk -> /usr/local/lib/node_modules/fdk/index.js


> jsonpath@1.0.0 postinstall /usr/local/lib/node_modules/fdk/node_modules/jsonpath

> node lib/aesprim.js > generated/aesprim-browser.js


sh: generated/aesprim-browser.js: Permission denied

npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.


npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! jsonpath@1.0.0 postinstall: `node lib/aesprim.js > generated/aesprim-browser.js`

npm ERR! Exit status 1

npm ERR! 

npm ERR! Failed at the jsonpath@1.0.0 postinstall script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


The above is occurring using Node 10.15.0 on macOS 10.14.2 Mojave.


To narrow down the issue, I tried installing the latest FDK on a fresh install of Debian 9.6 using Node 10.15.0. When doing so, the same issue occurs. (See attached.) It happens without sudo and using sudo.


Being fairly new to Node, I'm not sure where to start on troubleshooting this. Is this an issue with this specific version of Node? Is it an error in the latest FDK?


4 people have this problem

Same issue when moving from 4.5.1 to 4.6.1.  However I can reinstall 4.5.1 and every works OK, but I regularly get prompts to upgrade fdk whenever I run it.

Hi Travis,


 FDK requires node v6. Can you try installing fdk-4.6.1 using node v6? Please let me know if you face the same problem with fdk installation with node v6.

I am running node.js version v8.11.4.  So not sure what you mean by v6.  Please provide the full node.js version number.

I installed Node.js 6.16.0 in Debian 9.6 and then installed FDK 4.6.1. While it appears to have installed successfully, there are still quite a few warnings about packages being deprecated or requiring peer to a package. (See attached.)


This is where I was confused. Per the documentation on https://developers.freshservice.com/docs/quick-start/#install_node, it states the following:

"You will need to install Node.js to use Freshworks CLI. You can install node.js from here (any version below 6.10 will not be supported)."


The way this is worded, it sounds like any version of Node above 6.10 will work. However, if the FDK requires specifically the 6.x series of Node to be installed, then this needs to be much more clearly stated on the install instructions. Otherwise, people are going to install more recent versions. (Much like myself and David.)


So that leaves me with a couple of things:

1. The instructions need to be clearer about which version of Node is required / supported.

2. A clearer understanding on if all the WARN messages are expected and will not affect the use of the FDK.


txt

Hello Travis and David.


Apologies for all this confusion. Unfortunately, the instructions in our Freshservice developer documentation is not as clear as what we specify here - https://developer.freshdesk.com/v2/docs/quick-start/#install_node


What we really mean is that only Node versions 6.10.x are currently supported.


We will address the documentation to be much clearer. Thank you for the feedback.

We will look at the warnings closely as well and address them.


Do let us know if there are other points you think we could address.


1 person likes this

Still experiencing the same problem.  I find only version 4.5.1 works, but I am always prompted to do an upgrade.


Here is the log  

? A new version of the Freshworks CLI is available, Would you like to install it
 now? (Yes/No) yes
[sudo] password for *******: 
npm WARN deprecated json-schema-faker@0.5.0-rc13: Broken not support
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated nomnom@1.5.2: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.
/usr/bin/fdk -> /usr/lib/node_modules/fdk/index.js

> jsonpath@1.0.1 postinstall /usr/lib/node_modules/fdk/node_modules/jsonpath
> node lib/aesprim.js > generated/aesprim-browser.js

sh: 1: cannot create generated/aesprim-browser.js: Permission denied
npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.

npm ERR! code ELIFECYCLE
npm ERR! errno 2
npm ERR! jsonpath@1.0.1 postinstall: `node lib/aesprim.js > generated/aesprim-browser.js`
npm ERR! Exit status 2
npm ERR! 
npm ERR! Failed at the jsonpath@1.0.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/******/.npm/_logs/2019-03-04T10_44_03_477Z-debug.log
Installation failed - Command failed: sudo npm install https://dl.freshdev.io/cli/fdk-4.8.1.tgz -g
(node:1237) UnhandledPromiseRejectionWarning: Error: Cannot find module './lib/cli/run'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:613:15)
    at Function.Module._load (internal/modules/cjs/loader.js:539:25)
    at Module.require (internal/modules/cjs/loader.js:667:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at /usr/lib/node_modules/fdk/index.js:199:5
    at async.waterfall (/usr/lib/node_modules/fdk/lib/updater.js:178:5)
    at /usr/lib/node_modules/fdk/node_modules/async/dist/async.js:473:16
    at next (/usr/lib/node_modules/fdk/node_modules/async/dist/async.js:5329:29)
    at /usr/lib/node_modules/fdk/node_modules/async/dist/async.js:969:16
    at checkAddonVersion (/usr/lib/node_modules/fdk/lib/updater.js:159:16)
(node:1237) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:1237) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. 

  

log

Please can I have an update as I am still unable to install 4.6.1 and the proposed solution does not work.

Hi David,


From the log file that you've provided, I could see that you are using Node v11 instead of supported Node v6.10.X ( Note,  Node version and NPM version, both are different)


This might be the case, While you were using FDK 4.5.1  you've actually downloaded the right way on Node v6.10.X, but by the time when you wanted to update to FDK 4.6.1 you may have updated your Node v6.10.X to Node v11. 


Please give it a try, and drop a message here again, if you face any issues.

I cannot install Node 6.10.x as it is not supported on Ubuntu 18.04 (bionic).  Indeed, the end of life date for Node 6.10.x is 30 April 2019.   https://nodejs.org/en/about/releases/

There is a problem in that Node v6.10.x is not supported on Ubuntu 18.04.  There is a secondary issue in that the maintenance level of support for Node 6.10.x is due to expire on 30 April 2019.


Therefore after removing node, I have had to go back to version 4.5.0 as this works with Node v11.  I have tried Node v8 and experience the same issues.

Hi David,


Any linux OS which can support x86 or ARM binaries would be support node installation,  implies Ubuntu 18.04, should ideally be able to support. That should help you install FDK 4.6.1


We will soon support Node v8 instead of Node v6.10.X.



The issue is that Node 6.10 is not supported on Ubuntu 18.04.  I have tried both Node v8 and Node v11 with FDK 4.6.1 and I am unable to install FDK v4.6.1, however I am able to install FDK v4.5.0 in both versions.  Using Google, the problem I am experiencing appears to be associated with a version incompatibility that you are using and that comes installed with FDK v4.6.1.

Hi David,


Thanks for letting us know, however Ubuntu 18.04 does support Node 6.10.X. If you could attach some sort  of error log that you're facing during this process, I would be able to help you better.


Along the way, We're working to make FDK support for newer versions of node real soon as well.


Hi all,

it seems I have the same issue, I tried to install FDK v5.0.0 but I got error and can't get further. I have installed Node v8.10.0. For both I didn't find any other option. 

 

Login or Signup to post a comment
JS Bin