Start a new topic

Asset Report Bugs

Unable to get any help from Freshservice on this, maybe the community can help. I create a custom report for Assets to filter by Company (running in MSP mode). Realize some things are incorrect so I need to update them. Save and Regenerate report again and the chart still shows old data but the tabular data is accurate. A chat support person tried to tell me custom report data only gets updated every 4 hours and yet my tabular data is up to date to the minute. Makes no sense. Is there any way to clear out cache or similar to get chart to update? Report exhibits same incorrect data when exported to PDF as well. Unfortunately no way to hide the chart completely.

Also, in order to make my report actually usable I need fields like Serial Number, Warranty Start/End date but can't figure out how to add them to the report. Has anyone figured this out? The "add column" drop down says you can add up to 30 columns but it only provides a total of 17 columns to add, how do we add the others?


If I can't get my data out of the system to share with clients then there's ZERO point in actually putting it into the system.


Thanks in advance for any tips.

Hi Phill,

Custom Reports sync once every 4hours. The reason for the mismatch in the Tabular and the Pictorial Representation is that the Reports take the conditions or criteria given to provide the data accordingly. 


For Example- There is a report that I generate to show me the tickets that are Open during a certain time of the day(say 8AM- 11AM). Once the report is generated and if a ticket is closed post the sync, they would still appear in the report as they matched the conditions during the course of the Sync. The tabular data however, would display a more real-time version of the Report and show them with the ticket that has been satisfying the conditions during the sync though the Status of the ticket has been changed post the sync.

We are already working towards bringing real time reports and will keep you posted once its released.

-Jayesh
Freshservice Support

Login or Signup to post a comment