Start a new topic
Solved

Unable to perform local testing?

If you are using the request API or data store feature in your app, you will need to enable the "Load unsafe scripts" option in the browser to test your app.


During local testing, you may see a shield icon in the browser address bar, clicking on the icon will display a warning message. This message is displayed because the support portal runs on HTTPS while the server that is used for local testing runs on HTTP. Click the "Load unsafe scripts" link to continue your local testing.


image



when i run it locally and enter the command FDK RUN. that shield icon doesnt even show up. I know that everything was installed properly but it cannot get the template app to run

You can launch google chrome using command 'google-chrome --allow-running-insecure-content'



1 person likes this

Recently, Chrome’s latest versions started not to show any kind of Security prompt on the URL bar leaving no way for the user to allow Insecure Content on prompt.


Note: Insecure content is basically the app that developer has written and is trying to test run. But Browser identifies it as Insecure.


Solution

  1. Open Chrome Settings and select Privacy & Security.

  2. Select Site Settings.

  3. Select Insecure Content

  4. In the Allow section, add the Freshdesk account URL where app is going to run.

  5. Now the browser should allow developer app to test run.

I am having issues with load unsafe scripts in Mozilla Firefox. When testing applications, I would like to test across all the browsers we use. However, in firefox I am struggling to find the correct setting to allow insecure content. Any one else having this issue, or have a solution?. 

Zachary,


I just tried running a sample app on my Firefox 76 on MacOS Mojave. It worked fine.


App run successfully without any issues although Browser console threw some warnings.


Need a favour, As soon as you run the app, can you please share the screenshot of console logs(At the time of Page loads and At the time of App loads). On the other end, try to click the violet color shield icon and turn off the protection. Let me know that helped you make some progress.

Saif,


Attached is a screenshot of the console logs from the page load and when the app should load but doesn't. Also the shield (tracker) was already disabled. Not sure how else to allow load of unsafe scripts. Thank you for looking into this for me.


Hi Zach,


If the issue persists, can you share me the version of your browser. You can use https://www.whatismybrowser.com/ to share a browser details via provided unique link. This will help us find what browser expects to do if it has to allow CORS requests.


Here is a support article on how to allow Mixed content blocking from firefox - https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox

On a side note,


We have recently launched forum for Freshworks developer community (https://community.developers.freshworks.com). We encourage all the developers to discuss queries, ambiguities, know-hows, and points of interest with fellow app developers and Freshworks’ engineers on the forum.  We will involve the stakeholders directly on the forum topic to help you get your answers quicker.

Login or Signup to post a comment